Assistente de origens de dados - Ecrã 1

No primeiro ecrã do assistente, pode especificar o nome a descrição da origem de dados, assim como o nome do servidor que executa o Microsoft SQL Server ao qual a origem de dados será ligada.

Caixa Nome

O nome da origem de dados utilizado por uma aplicação de ODBC quando esta solicita uma ligação à origem de dados. Por exemplo, “Pessoal”. O nome da origem de dados é apresentado na caixa de diálogo Administrador da origem de dados de ODBC.

Caixa Descrição

Uma descrição opcional da origem de dados. Por exemplo, “Data da contratação, histórico do salário e revisão actual de todos os empregados”.

Caixa Servidor

O nome de um servidor de SQL existente na rede. Se seleccionar o nome de um servidor na lista, não será necessária uma configuração adicional. Se introduzir o nome de um servidor que não exista como uma entrada do utilitário SQL Server Client Configuration, pode criar um alias de servidor para o novo nome no ecrã seguinte do assistente.

Pode escrever "(local)" na caixa do servidor quando estiver a utilizar o mesmo computador como servidor de SQL. Depois, o utilizador pode estabelecer ligação à cópia local do SQL Server, mesmo quando estiver a ser executada uma versão do SQL Server que não esteja em rede. O SQL Server 2000 suporta várias ocorrências do SQL Server em execução no mesmo computador. Para especificar uma determinada ocorrência do SQL Server, o nome do servidor é especificado como NomeServidor\NomeOcorrência.

Para mais informações sobre nomes de servidores para diferentes tipos de rede, consulte a documentação de instalação do SQL Server em SQL Server Books Online.

Se as informações especificadas neste ecrã forem as necessárias para ligar ao SQL Server, pode clicar em Concluir. Serão utilizadas as predefinições de todos os atributos especificados noutros ecrãs do assistente.

©1988-2000 Microsoft Corporation. Todos os direitos reservados.


Assistente de origens de dados - Ecrã 2

No segundo ecrã do assistente, pode especificar o método de autenticação e configurar as entradas avançadas de cliente do Microsoft® SQL Server™, assim como o início de sessão e a palavra-passe que o controlador de ODBC para SQL Server irá utilizar para ligar ao SQL Server enquanto configura a origem de dados.

Botão de opção Com a autenticação do Windows NT usando o ID de início de sessão de rede

Especifica que o controlador de ODBC para SQL Server pedirá uma ligação segura (ou fidedigna) a um SQL Server em execução no Microsoft Windows NT ou no Windows 2000. Quando seleccionada, o SQL Server utilizará a segurança integrada de início de sessão para estabelecer ligações utilizando esta origem de dados, independentemente do modo actual de segurança de início de sessão existente no servidor. Será ignorado qualquer ID de início de sessão ou palavra-passe fornecida. O administrador de sistema do SQL Server tem de ter o seu início de sessão do Microsoft Windows® associado a um ID de início de sessão no SQL Server.

Botão de opção Com a autenticação do SQL Server usando um ID e uma palavra-passe introduzidos pelo utilizador

Especifica que o controlador de ODBC para SQL Server não pedirá uma ligação segura (ou fidedigna) ao SQL Server. Quando seleccionado, o SQL Server utiliza a segurança padrão no início de sessão para estabelecer ligações utilizando esta origem de dados. Tem de especificar um ID de início de sessão e uma palavra-passe de SQL Server para todos os pedidos de ligação.

Botão Configuração do cliente

Inicia a caixa de diálogo que permite adicionar uma nova configuração de biblioteca de rede do utilitário SQL Server Client Configuration.

Se especificou um novo nome na caixa Servidor do primeiro ecrã do assistente, poderá ter de utilizar esta caixa de diálogo para adicionar uma entrada de configuração de um alias de servidor cujo nome corresponda ao nome especificado na caixa Servidor do primeiro ecrã do assistente de ODBC. O nome alias tem de corresponder ao nome especificado na caixa Servidor. Para o Microsoft SQL Server, não é necessária uma configuração de nome alias de servidor. Na maior parte dos casos, o controlador de ODBC para SQL Server pode estabelecer ligação utilizando a biblioteca de rede predefinida e o nome de rede fornecido na caixa Servidor do primeiro ecrã do assistente.

Clique em Configuração do cliente se pretender que a ligação utilize uma biblioteca de rede que não seja a biblioteca de rede predefinida do cliente. Clique também em Configuração do cliente se, para conseguir uma ligação com êxito, for necessário especificar o endereço de rede real do servidor. Por exemplo, quando utilizar a biblioteca de rede TCP/IP, poderá ser necessário especificar o endereço da porta e do socket do servidor ou, se um servidor de SQL estiver a receber num encaminhamento designado alternativo, terá de especificar o nome do encaminhamento na entrada avançada.

Para mais informações sobre como configurar clientes, consulte SQL Server Books Online.

Caixa de verificação Ligar ao SQL Server para obter as predefinições das opções de configuração adicionais

Quando seleccionada, o controlador do SQL Server obtém as definições iniciais do servidor de SQL para as opções dos ecrãs seguintes do assistente. O controlador do SQL Server liga ao servidor de SQL especificado na caixa Servidor do primeiro ecrã.

Quando desmarcada, o controlador do SQL Server obtém as definições iniciais do servidor de SQL para as opções dos ecrãs seguintes do assistente.

Caixa ID de início de sessão

Especifica o ID de início de sessão utilizado pelo controlador do SQL Server durante a ligação ao SQL Server, caso a opção Com a autenticação do SQL Server usando um ID e uma palavra-passe introduzidos pelo utilizador esteja seleccionada. Só é aplicada à ligação estabelecida para determinar as predefinições do servidor; não se aplica a ligações subsequentes estabelecidas através da utilização da origem de dados depois da respectiva criação.

Caixa Palavra-passe

Especifica a palavra-passe utilizada pelo controlador do SQL Server durante a ligação ao SQL Server, caso a opção Com a autenticação do SQL Server usando um ID e uma palavra-passe introduzidos pelo utilizador esteja seleccionada. Só é aplicada à ligação estabelecida para determinar as predefinições do servidor; não se aplica a ligações subsequentes estabelecidas através da utilização da nova origem de dados.

As caixas ID de início de sessão e Palavra-passe estão desactivadas se a opção Com a autenticação do Windows NT usando o ID de início de sessão de rede estiver seleccionada ou se a opção Ligar ao SQL Server para obter as predefinições das opções de configuração adicionais não estiver seleccionada.


Assistente de origens de dados - Ecrã 3

No terceiro ecrã do assistente, pode especificar a base de dados predefinida, a forma como o controlador deve utilizar os procedimentos armazenados para suportar SQLPrepare, várias opções ANSI a utilizar pelo controlador e se deverá ser utilizado um servidor de reserva.

Caixa Alterar a base de dados predefinida para

Especifica o nome da base de dados predefinida de qualquer ligação estabelecida utilizando esta origem de dados. Quando desmarcada, as ligações utilizam a base de dados predefinida para o ID de início de sessão no servidor. Quando seleccionada, a base de dados especificada na caixa substitui a base de dados predefinida para o ID de início de sessão. Se a caixa Anexar nome de ficheiro da base de dados tiver o nome de um ficheiro principal, a base de dados descrita pelo ficheiro principal será anexada como uma base de dados utilizando o nome da base de dados especificada na caixa Alterar a base de dados predefinida para.

A utilização da base de dados predefinida para o ID de início de sessão é mais eficaz do que a especificação de uma base de dados predefinida na origem de dados de ODBC.

Anexar nome de ficheiro da base de dados

Especifica o nome do ficheiro principal para uma base de dados que pode ser anexada. Esta base de dados é anexada e utilizada como a base de dados predefinida da origem de dados. Especifique o caminho completo e o nome do ficheiro principal. O nome da base de dados especificado na caixa Alterar a base de dados predefinida para é utilizado como o nome da base de dados anexada.

Caixa de verificação Criar procedimentos armazenados temporários para instruções de SQL preparadas e ignorar os procedimentos armazenados

Quando desmarcada, o controlador do Microsoft® SQL Server™ não cria procedimentos armazenados de modo a suportar a função de ODBC SQLPrepare. Quando seleccionada, o controlador do SQL Server cria procedimentos armazenados temporários de modo a suportar a função de ODBC SQLPrepare. Esta caixa de verificação e as respectivas opções associadas só são relevantes durante a ligação a versões mais antigas do SQL Server.

Botão de opção Apenas quando desligar

Especifica que os procedimentos armazenados temporários criados para SQLPrepare são ignorados quando a função de ODBC SQLDisconnect é chamada. Desta forma, o controlador poderá voltar a utilizar os procedimentos armazenados, caso a mesma instrução de SQL seja preparada várias vezes, reduzindo, ao mesmo tempo, o processamento geral adicional associado ao facto de ignorar os procedimentos armazenados durante a execução da aplicação. Se seleccionar esta opção para uma aplicação que funcione durante muito tempo sem ser desligada ou para uma aplicação que emita muitas chamadas de SQLPrepare, poderá levar à criação de procedimentos armazenados temporários.

Botão de opção Quando desligar e conforme as necessidades enquanto estiver ligado

Especifica que os procedimentos armazenados temporários criados para SQLPrepare são ignorados quando chamar SQLDisconnect, quando chamar SQLFreeHandle para o controlo da instrução, quando chamar SQLPrepare ou SQLExecDirect para processar uma nova instrução de SQL no mesmo controlo da instrução ou quando for chamada uma função de catálogo. Pode ser causado algum processamento geral adicional uma vez que os procedimentos armazenados temporários são ignorados durante a execução da aplicação, impedindo, no entanto, a criação de procedimentos armazenados temporários para aplicações de execução longa.

Caixa de verificação Utilizar identificadores ANSI entre aspas

Especifica que QUOTED_IDENTIFIERS é activado quando o controlador de ODBC para SQL Server for ligado. Quando seleccionada, o SQL Server aplica as regras ANSI com aspas. As aspas só podem ser utilizadas para identificadores como, por exemplo, nomes de colunas e de tabelas. As cadeias de caracteres têm de estar entre plicas:

SELECT "au_id"
FROM "autores"
WHERE "au_lname" = 'O''Brien'

Quando desmarcada, as aplicações que utilizam identificadores entre aspas como, por exemplo, o utilitário Microsoft Query enviado com o Microsoft Excel, deparam com erros quando criam instruções de SQL com identificadores entre aspas.

Caixa de verificação Utilizar nulos, preenchimentos e avisos ANSI

Especifica que as opções ANSI_NULLS, ANSI_WARNINGS e ANSI_PADDINGS são activadas quando o controlador do SQL Server for ligado.

Com a opção ANSI_NULLS activada, o servidor aplica as regras ANSI relativas à comparação de colunas para NULL. A sintaxe ANSI “IS NULL” ou “IS NOT NULL” tem de ser utilizada para todas as comparações NULL. A sintaxe de Transact-SQL “= NULL” não é suportada.

Com a opção ANSI_WARNINGS activada, o SQL Server emite mensagens de aviso para condições que violem as regras ANSI, mas que não violem as regras de Transact-SQL. Alguns exemplos desses erros são o truncamento de dados durante a execução de uma instrução INSERT ou UPDATE ou o aparecimento de um valor nulo durante uma função de agregação.

Com a opção ANSI_PADDING activada, os espaços em branco no fim em valores varchar e os zeros à direita em valores varbinary não são automaticamente cortados.

Caixa de verificação Utilizar o servidor SQL de reserva se o servidor de SQL principal não estiver disponível

Especifica que, quando for definido um servidor de reserva para o SQL Server especificado na origem de dados, o controlador de SQL Server reúne informações de ligação para o servidor de reserva quando este ligar ao servidor principal especificado. Se a aplicação perder a respectiva ligação ao SQL Server principal, vai limpar a respectiva transacção actual e tentará voltar a ligar ao SQL Server principal. Se o controlador detectar que o servidor principal não está disponível, ligará automaticamente ao servidor de reserva. Esta opção está desactivada se o servidor não suportar operações de reserva.


Assistente de origens de dados - Ecrã 4

No quarto ecrã do assistente, pode especificar o idioma a ser utilizado nas mensagens do Microsoft® SQL Server™, a conversão de conjuntos de caracteres e se o controlador do SQL Server deverá utilizar as definições regionais. Também pode controlar o registo de consultas de longa duração e de definições de estatísticas do controlador.

Caixa Alterar o idioma das mensagens do sistema do SQL Server para

Cada SQL Server pode ter vários conjuntos de mensagens do sistema, cada um deles com um idioma diferente (inglês, espanhol, francês, entre outros) definido. Se uma origem de dados for definida para um servidor que tenha vários conjuntos de mensagens do sistema, pode especificar qual o idioma que pretende utilizar para essas mensagens do sistema. Na lista, clique no idioma. Esta opção não estará disponível se só estiver instalado um idioma no SQL Server.

Caixa de verificação Efectuar conversão para dados de caracteres

Quando seleccionada, o controlador de ODBC para SQL Server converte cadeias ANSI enviadas entre o computador cliente e o SQL Server utilizando Unicode. Por vezes, o controlador de ODBC para SQL Server utiliza a conversão entre a página de códigos do SQL Server e Unicode no computador cliente. Para tal, a página de códigos utilizada pelo SQL Server tem de ser uma das páginas de códigos disponíveis no computador cliente.

Quando desmarcada, não é efectuada nenhuma conversão de caracteres expandidos em cadeias de caracteres ANSI durante a respectiva transmissão entre a aplicação cliente e o servidor. Se o computador cliente estiver a utilizar uma página de códigos ANSI (ACP) diferente da página de códigos do SQL Server, os caracteres expandidos em cadeias de caracteres ANSI poderão ser considerados incorrectos. Se o computador cliente estiver a utilizar a mesma página de códigos para a respectiva ACP que está a ser utilizada pelo SQL Server, os caracteres expandidos serão correctamente interpretados.

Caixa de verificação Utilizar definições regionais ao emitir moedas, números, datas e horas

Especifica que o controlador utiliza as definições regionais do computador cliente para a formatação de moedas, números, datas e horas em cadeias de caracteres de saída. O controlador utiliza a predefinição regional da conta de início de sessão no Microsoft Windows® 95/98, no Microsoft Windows NT® ou no Microsoft Windows 2000 do utilizador que está a ligar através da origem de dados. Seleccione esta opção para as aplicações que apenas apresentam dados e não para as aplicações que processam dados.

Caixa Guardar consultas de longa duração no ficheiro de registo

Especifica que o controlador regista quaisquer consultas que demorem mais tempo do que o valor Tempo de consulta de longa duração. As consultas de longa duração são registadas no ficheiro especificado. Para especificar um ficheiro de registo, escreva o caminho completo e o nome do ficheiro na caixa ou clique em Procurar para seleccionar um ficheiro de registo percorrendo os directórios de ficheiros existentes.

Caixa Tempo de consulta de longa duração (milissegundos)

Especifica um valor de limiar, em milissegundos, para o registo de consultas de longa duração. São registadas todas as consultas cuja execução demore mais do que o número de milissegundos especificado.

Caixa Registar estatísticas do controlador de ODBC no ficheiro de registo

Especifica que as estatísticas serão registadas. As estatísticas são registadas no ficheiro especificado. Para especificar um ficheiro de registo, escreva o caminho completo e o nome do ficheiro na caixa ou clique em Procurar para seleccionar um ficheiro de registo percorrendo os directórios de ficheiros existentes.

O registo de estatísticas é um ficheiro delimitado por tabulações que pode ser analisado no Microsoft Excel ou noutra aplicação que suporte ficheiros delimitados por tabulações.


Caixa de diálogo Início de sessão no SQL Server

O controlador de ODBC para Microsoft® SQL Server™ mostra a caixa de diálogo Início de sessão no SQL Server quando chamar uma ligação de ODBC sem especificar informações suficientes para que o controlador consiga ligar a um servidor de SQL.

Quando a caixa de diálogo Início de sessão no SQL Server for apresentada pela primeira vez, contém apenas o seguinte:

Caixa Servidor ou o nome da origem de dados.

Caixa de verificação Utilizar ligação fidedigna.

Caixa ID de início de sessão.

Caixa Palavra-passe.

Botões OK, Cancelar e Opções.

Se clicar no botão Opções, a caixa de diálogo aumenta de modo a conter também o grupo Opções:

Caixa Base de dados

Caixa Idioma

Caixa Nome de aplicação

Caixa ID da estação de trabalho

Caixa Servidor

O nome de um servidor de SQL existente na rede. Se seleccionar o nome de um servidor na lista, não será necessária uma configuração adicional. Se escrever um nome de servidor, tem de ser uma entrada avançada no utilitário SQL Server Client Configuration ou o nome de rede de um servidor com o SQL Server. Esta caixa é substituída pelo nome da origem de dados (DSN) caso tenha especificado um DSN para a ligação.

Pode escrever "(local)" na caixa do servidor quando estiver a utilizar o mesmo computador como servidor de SQL. Depois, o utilizador pode estabelecer ligação com uma cópia local do SQL Server, mesmo quando estiver a ser executada uma versão do SQL Server que não esteja em rede.

Para mais informações sobre nomes de servidores para diferentes tipos de rede, consulte a documentação de instalação do SQL Server em SQL Server Books Online.

Caixa de verificação Utilizar ligação fidedigna

Quando seleccionada, especifica que o controlador de ODBC para SQL Server pedirá uma ligação segura (ou fidedigna) a um SQL Server em execução no Microsoft Windows NT® ou no Microsoft Windows 2000. Quando seleccionada, o SQL Server utilizará a segurança integrada de início de sessão para estabelecer ligações utilizando esta origem de dados, independentemente do modo actual de segurança de início de sessão existente no servidor. Será ignorado qualquer ID de início de sessão ou palavra-passe fornecida. O administrador de sistema do SQL Server tem de ter o seu ID de rede do Windows associado a um ID de início de sessão no SQL Server.

Quando desmarcada, o SQL Server utiliza a segurança padrão de início de sessão para estabelecer ligações utilizando esta origem de dados. Tem de especificar um ID de início de sessão e uma palavra-passe para todos os pedidos de ligação.

Caixa ID de início de sessão

Especifica o ID de início de sessão no SQL Server a utilizar para a ligação se não estiver seleccionada a caixa Utilizar ligação fidedigna. Se a caixa Utilizar ligação fidedigna estiver seleccionada, a caixa ID de início de sessão é desactivada.

Caixa Palavra-passe

Especifica a palavra-passe para o ID de início de sessão no SQL Server utilizada para a ligação se não estiver seleccionada a caixa Utilizar ligação fidedigna. Se a caixa Utilizar ligação fidedigna estiver seleccionada, a caixa Palavra-passe está desactivada.

Caixa Base de dados

Especifica a base de dados predefinida a utilizar na ligação. Esta base de dados substitui a base de dados predefinida especificada para o início de sessão no servidor. Se não for especificada nenhuma base de dados, a ligação utilizará a base de dados predefinida especificada para o início de sessão no servidor.

Caixa Idioma

Especifica o idioma nacional a utilizar para as mensagens de sistema do SQL Server. O SQL Server tem de ter o idioma instalado. Este idioma substitui o idioma predefinido especificado para o início de sessão no servidor. Se não for especificado nenhum idioma, a ligação utilizará o idioma predefinido especificado para o início de sessão no servidor.

Caixa Nome de aplicação

Especifica opcionalmente o nome da aplicação a armazenar na coluna program_name na linha desta ligação em master.dbo.sysprocesses.

Caixa ID da estação de trabalho

Especifica opcionalmente o ID da estação de trabalho a armazenar na coluna hostname na linha desta ligação em master.dbo.sysprocesses.


Copyright e exclusão de responsabilidade do Microsoft SQL Server 2000

Este documento, incluindo as aplicações exemplo, destina-se apenas a fins informativos e a Microsoft não concede nenhuma garantia, expressa ou implícita, neste documento. As informações contidas neste documento, incluindo exemplos, URLs e outras referências a Web sites da Internet, estão sujeitas a alterações sem aviso prévio. Todos os riscos de utilização ou dos resultados da utilização deste documento são da responsabilidade do utilizador.

O objectivo principal de um exemplo consiste em ilustrar um conceito ou uma utilização aceitável de uma determinada instrução ou cláusula. A maior parte dos exemplos não inclui a totalidade do código que seria normalmente encontrado num sistema completo, dado que muita da habitual validação de dados e do tratamento de erros é removido para destacar no exemplo um determinado conceito ou uma instrução. Não está disponível suporte técnico para estes exemplos ou para o código fonte fornecido.

Os nomes de empresas, organizações, produtos, pessoas e eventos mencionados neste documento são fictícios e não se destinam, de todo, a representar qualquer empresa, organização, produto, pessoa ou evento real, salvo indicação em contrário. A conformidade com todas as leis de copyright aplicáveis é da inteira responsabilidade do utilizador. Sem limitação dos direitos protegidos por copyright, nenhuma parte desta publicação deverá ser reproduzida, armazenada ou introduzida num sistema de recuperação ou transmitida de alguma forma ou por qualquer meio (electrónico, mecânico, através de fotocópia, gravação ou outros) ou para qualquer finalidade, sem a permissão por escrito da Microsoft Corporation.

Nesta publicação, a Microsoft pode ter patentes, pedidos de patente pendentes, marcas comerciais, copyrights ou outros direitos de propriedade intelectual. Com excepção do estipulado expressamente em qualquer acordo de licenças escrito pela Microsoft, o facto de este documento lhe ser fornecido não lhe confere quaisquer direitos sobre essas patentes, marcas comerciais, copyrights ou outras formas de propriedade intelectual.

©1996-2000 Microsoft Corporation. Todos os direitos reservados.

Active Directory, ActiveX, BackOffice, CodeView, Developer Studio, FoxPro, JScript, Microsoft, Microsoft Press, Microsoft SQL Server, MSDN, MS-DOS, Outlook, PivotChart, PivotTable, PowerPoint, Visual Basic, Visual C++, Visual Studio, Win32, Windows 2000, Windows e Windows NT são marcas registadas ou comerciais da Microsoft Corporation nos Estados Unidos e/ou noutros países.

Os nomes das empresas e produtos reais mencionados nesta publicação podem ser marcas comerciais dos respectivos proprietários.

Versão: 8.00.000

©1988-2000 Microsoft Corporation. Todos os direitos reservados.